Question

5
Replies
714
Views
SachinK0 Member since 2016 4 posts
Global Payments
Posted: 3 years ago
Last activity: 3 years ago
Closed
Solved

Unable to send pdf data via SOAP as MTOM

Hi, As part of the Visa Claims Resolution process I am trying to connect to Visa's RTSI SOAP services to pass PDF data in the form of Base 64 encoded data via both MTOM and inline within xml. We are currently on 6.1 SP2 (not sure if it's supported on this version though we have options to send binary attachments on Connect-SOAP).

I was able to send the PDF data via SOAP UI, however the same is not working in Pega. I have followed the instructions mentioned in one of the PDN link to set the pyAttachmentPage - this is not working. Please refer to the attached document which has the configuration, request snippet and the raw header generated by Pega and SOAP UI and the error response.

My guess is due to the first Content Type generated by Pega - though it is multipart/related which is expected, the type is type="text/xml" instead of type="application/xop+xml". I see the Base 64 data that SOAP UI generates and Pega generates is the same - so there is no issue with data.

The error message returned by web service is - "The supplied MimeType element specified a PDF image, but the actual image was not a PDF"

Has anyone faced this issue earlier ? Is there a way I can update the ContentType's type="application/xop+xml" ? I am trying to see if I can do this in InvokeAxis2.

***Edited by Moderator Marissa to add SR Details***

Data Integration SR Created
Moderation Team has archived post
Share this page LinkedIn