Question

5
Replies
292
Views
SwarnenduB9083 Member since 2015 2 posts
ME Bank
Posted: January 24, 2017
Last activity: July 31, 2017
Closed

Upgrading socket.io version from "0.8.7" to greater than "1.0" in CoBrowse 7.21.7 to connect to App Dynamics 4.2.0

We have inpremise installation of cobrowse and using AppDynamics for monitoring all the servers.

But, facing the below error when launching the CoBrowse server with AppDynamics agent.

"err": "TypeError: Cannot read property 'listen' of undefined\n
at /opt/sit/cobrowse/server/node_modules/appdynamics/lib/core/proxy.js:206:19\n

As per the below link, the issue occurs due to older versions of socket.io. In the current CoBrowse server, the socket.io is using the version 0.8.7

https://community.appdynamics.com/t5/AppDynamics-Discussions/Node-JS-agent-throws-an-error/td-p/13398

Can you please advice that if the socket.io library is upgraded to version greater than "1.0" then there is any impact to the CoBrowse server

User Interface
Moderation Team has archived post
Share this page LinkedIn