Question

2
Replies
153
Views
Anurathan_K Member since 2016 17 posts
ANZ Bank
Posted: 4 years ago
Last activity: 3 years 8 months ago
Closed
Solved

Weblogic Split-schema issue for deploying prweb.war

Issue in deploying Pega 7.1.9 in Weblogic based on Split-Schema configuration.

1. JNDI datasource for JDBC connection is created in Weblogic

2. Plan.xml is modified based on the deployment guide

<deployment-plan xmlns="http://www.bea.com/ns/weblogic/90">
<application-name>dccore</application-name>
<variable-definition>
<variable>
<name>defaultRulesSchema</name>
<value>pegarules</value>
</variable>
<variable>
<name>defaultDataSchema</name>
<value>pegadata</value>
</variable>
</variable-definition>
<module-override>
<module-name>dccore.war</module-name>
<module-type>war</module-type>
<module-descriptor external="false">
<root-element>web-app</root-element>
<uri>WEB-INF/web.xml</uri>
<variable-assignment>
<name>defaultRulesSchema</name>
<xpath>/web-app/env-entry/[env-entry-name="prconfig/database/databases/PegaRULES/defaultSchema"]/env-entry-value</xpath>
<operation>replace</operation>
</variable-assignment>
<variable-assignment>
<name>defaultDataSchema</name>
<xpath>/web-app/env-entry/[env-entry-name="prconfig/database/databases/PegaDATA/defaultSchema"]/env-entry-value</xpath>
<operation>replace</operation>
</variable-assignment>
</module-descriptor>
</module-override>
<config-root>/u01/pega/MW_HOME/user_projects/domains/pega_domain/plan</config-root>
</deployment-plan>

Deployment failed with pr_data_admin does not exist. and other exceptions.

What should be done for this case?

Low-Code App Development Installation and Deployment
Moderation Team has archived post
Share this page LinkedIn