Question

4
Replies
1354
Views
JyothirmayiN Member since 2017 10 posts
Infosys
Posted: 3 years ago
Last activity: 3 years 5 months ago
Closed

How to deploy the Pega Robotics Automation solution with different MS Office version on end user system

Hi Team,

I have developed a solution having Microsoft Excel and Microsoft outlook Mail connectors containing the Office 2016 dlls as components.

But the end user system contains Microsoft Office 2013 and the solution is not executiong.

Steps followed in my machine are:

(1) Replaced the Microsoft.Office.Interop.Excel.dll and Microsoft.Office.Interop.Outlook.dll present in the path C:\Program Files (x86)\OpenSpan\OpenSpan Studio for Microsoft Visual Studio 2015 with the dlls present in the folder C:\Program Files (x86)\OpenSpan\OpenSpan Studio for Microsoft Visual Studio 2015\Office2013

(2) Changed the office version from 2016 to 2013 in RuntimeConfig.xml and StudioConfig.xml as well in the statement as follows from :

<add key="OfficeVersion" value="2016" /> to the following statement

<add key="OfficeVersion" value="2013" />

(3) When tried executing the solution the following error is fired. Please find the below two snapshots for reference

Could you please help me how to resolve this office versioning problems.

**Moderation Team has archived post**

This post has been archived for educational purposes. Contents and links will no longer be updated. If you have the same/similar question, please write a new post.

Robotic Process Automation
Moderation Team has archived post
Share this page LinkedIn