Question

7
Replies
611
Views
Marco Member since 2018 10 posts
Ericsson
Posted: April 27, 2018
Last activity: February 20, 2019
Closed
Solved

Designer Studio & Deploy to Server

Hi all.

I'm trying to integrate Designer Studio with Package Server and Robot Manager in order to "Deploy to Server" from Designer studio.

This is my configuration

CommonConfig.xml

<Servers>
	<!-- enabled= "true" connessione con il robot Manager & Publish to server -->
	<!-- RPA="true" ???? -->
	<!-- baseURL="http://localhost:8080/prweb"  url di Pega Server -->
	<!-- authenticationType	??? -->
		<Server name="RobotManager" baseURL="http://localhost:9080/prweb" enabled="true" proxyAddress="" RPA="true" authenticationType="Basic" workgroup="Customer service" robotName="Cust00"/>
		<Server name="Config" baseURL="https://omc.openspan.com/" enabled="false" proxyAddress=""/>
		<Server name="Intelligence" baseURL="https://WFIID-wfi.openspan.com" enabled="false" proxyAddress=""/>
		<Server name="IdP" baseURL="https://HiroAuthServer.com/Endpoint" enabled="false" proxyAddress=""/>
</Servers>

StudioConfig.xml

  <Robotics>
    <!-- baseUrl: Address of Pega API endpoint -->
    <PegaServer baseUrl="https://localhost:8080/prweb/api/v1/" />
	<RDA_Credentials userName="Admin@BankerPro" password="rules"/>
    <!-- PackageServer baseUrl: Address of the Package Server API endpoint. -->
    <PackageServer baseUrl="http://localhost:5000" />
  </Robotics>

RuntimeConfig.xml

  <Robotics>
    <PegaServer baseUrl="http://localhost:8080/prweb/api/v1/" />
	<LocalApiService enabled="true" SSL="true" port="9443" allowedOrigins="*" JWTSecurity="false" PegaServerURL="http://localhost:8080/prweb/api/v1/" /> --&gt;
	<PackageServer baseUrl="http://localhost:5000" />
    <!-- PackageServer baseUrl: Address of the Package Server API endpoint. -->
  </Robotics>

I am run the Package Server:

PackageServer.exe --urls “http://serverHostName:5000

and

ServerStatus.exe --urls “http://serverHostName:5005

I am launch Designer Studio and I have to enter user and password... but what?

Are not the user\password use to connect Pega Platform (eg. admin@bankerpro\rules)?

Can you help me?

Regards,

Marco

Low-Code App Development Dev/Designer Studio Robotic Process Automation
Moderation Team has archived post
Share this page LinkedIn