Question

30
Replies
1275
Views
Close popover
adam kennedy (adamk317)
anthem

anthem
US
adamk317 Member since 2015 1 post
anthem
Posted: November 13, 2015
Last activity: November 23, 2015
Closed

May I have assistance with my system failures in the Post Deployment Configuration Portion of the upgrade?

I am not an Expert Pega User.  I have been struggling with my Upgrade for the last week and when I finally dumped domain User Ids and Integrated Security I was able to make Progress.  I feel that I have followed the two documents I have. 1) the PreUpgrade Assessment and 2) the Pega7.1.8 Upgrade Guide.   I will attach as much information as you would care to see.  My upgrade says it was successful.  The WebSphere work looks correct.  I am unable to get the Application to start.  It complains in the browser about

PegaRULES Web Application Error

Message: An has occurred processing this request. Please contact your system administrator.

Unable to obtain build properties due to java.lang.reflect.InvocationTargetException: null

and it complains in the WebSphere Logs that

************ Start Display Current Environment ************

WebSphere [IBMJAVA71 7.1.2.0 cf041446.01]Platform 8.5.5.4 [ND 8.5.5.4 cf041446.03] running with process name PEGA_va10n50735DEVCell01A\PEGA_va10n50736DEVNode01\DEV_PEGA_736 and process id 5932

Host Operating System is Windows, version 6.3

Java version = 1.7.0, Java Runtime Version = pwa6470_27sr2ifx-20141115_01 (SR2+IV66608+IV66375+IV66944 SR2+IV66608+IV66375+IV66944), Java Compiler = j9jit27, Java VM name = IBM J9 VM

was.install.root = E:\IBM\WebSphere\AppServer

user.install.root = E:\IBM\WebSphere\AppServer\profiles\dev_pega_mngd_node

Java Home = E:\IBM\WebSphere\AppServer\java_1.7.1_64\jre

ws.ext.dirs = E:\IBM\WebSphere\AppServer/java_1.7.1_64/lib;E:\IBM\WebSphere\AppServer\profiles\dev_pega_mngd_node/classes;E:\IBM\WebSphere\AppServer/classes;E:\IBM\WebSphere\AppServer/lib;E:\IBM\WebSphere\AppServer/installedChannels;E:\IBM\WebSphere\AppServer/lib/ext;E:\IBM\WebSphere\AppServer/web/help;E:\IBM\WebSphere\AppServer/deploytool/itp/plugins/com.ibm.etools.ejbdeploy/runtime

Classpath = E:\IBM\WebSphere\AppServer\profiles\dev_pega_mngd_node/properties;E:\IBM\WebSphere\AppServer/properties;E:\IBM\WebSphere\AppServer/lib/startup.jar;E:\IBM\WebSphere\AppServer/lib/bootstrap.jar;E:\IBM\WebSphere\AppServer/lib/jsf-nls.jar;E:\IBM\WebSphere\AppServer/lib/lmproxy.jar;E:\IBM\WebSphere\AppServer/lib/urlprotocols.jar;E:\IBM\WebSphere\AppServer/deploytool/itp/batchboot.jar;E:\IBM\WebSphere\AppServer/deploytool/itp/batch2.jar;E:\IBM\WebSphere\AppServer/java_1.7.1_64/lib/tools.jar

Java Library path = E:\IBM\WebSphere\AppServer/lib/native/win/x86_64/;E:\IBM\WebSphere\AppServer\java_1.7.1_64\jre\bin\compressedrefs;E:\IBM\WebSphere\AppServer\java_1.7.1_64\jre\bin;C:\Windows\system32;C:\Windows;E:\IBM\WebSphere\AppServer\lib\native\win\x86_64;E:\IBM\WebSphere\AppServer\bin;E:\IBM\WebSphere\AppServer\java_1.7.1_64\bin;E:\IBM\WebSphere\AppServer\java_1.7.1_64\jre\bin;C:\Windows\system32;C:\Windows;C:\Windows\System32\Wbem;C:\Windows\System32\WindowsPowerShell\v1.0\;C:\IBM\ITM\bin;C:\IBM\ITM\InstallITM;C:\IBM\ITM\TMAITM6;

Orb Version = IBM Java ORB build orb727-20140912.00

************* End Display Current Environment *************

[11/13/15 8:45:21:753 EST] 000000a6 webapp        I com.ibm.ws.webcontainer.webapp.WebApp log SRVE0296E: [prpc_j2ee14_ws#prweb.war][/prweb][Servlet.LOG]:.Web Application Error: :.javax.servlet.ServletException: SRVE0207E: Uncaught initialization exception created by servlet

at com.ibm.ws.webcontainer.servlet.ServletWrapper.init(ServletWrapper.java:404)

at com.ibm.ws.webcontainer.servlet.ServletWrapperImpl.init(ServletWrapperImpl.java:168)

AND ....

============ PegaRULES Bootstrap Configuration ============
           Date: Fri Nov 13 08:53:56 EST 2015
   Java Version: IBM Corporation 1.7.0
  Configuration: wsjar:file:/E:/IBM/WebSphere/AppServer/profiles/dev_pega_mngd_node/installedApps/PEGA_va10n50735DEVCell01A/prpc_j2ee14_ws.ear/APP-INF/lib/prresources.jar!/prbootstrap.properties
Pega-EngineCode:
       Database: Microsoft SQL Server 11.00.5613
         Driver: Microsoft JDBC Driver 4.1 for SQL Server 4.1.5605.100

Unable to use given database configuration
Unable to locate classes on filesystem
=============== End Bootstrap Configuration ===============

[11/13/15 8:53:56:345 EST] 000000a6 PRBootstrap   E com.pega.pegarules.internal.bootstrap.PRBootstrap  Error initializing PRAppLoader
                                 java.lang.ClassNotFoundException: com.pega.pegarules.internal.bootstrap.phase2.PRBootstrapImpl
at com.pega.pegarules.internal.bootstrap.PRMiniLoader.loadClass(PRMiniLoader.java:388)
at java.lang.ClassLoader.loadClass(ClassLoader.java:847)

What part of the process should I redo to determine the Root Cause of this issue?

thanks,

adam

System Administration Upgrades
Moderation Team has archived post,
Close popover This thread is closed to future replies. Content and links will no longer be updated. If you have the same/similar Question, please write a new Question.