Question

8
Replies
206
Views
OleksandrByelyenov Member since 2016 40 posts
Sberbank
Posted: 3 years ago
Last activity: 3 years 1 month ago
Closed
Solved

Updated translation in a Zip-file aren't accepted.

Hello, I have an issue with updating localization settings. I download a zip-file, unpack it, update translations and compress it into zip and upload back.
First of all I created my own copy of production application and provided a branch with a Branch RuleSet in it.
After that I performed localization according to this instruction https://pdn.pega.com/sites/pdn.pega.com/files/help_v718/procomhelpmain.htm#tools/localization/aboutlocalization.htm

So, my prerequisites are:
1) Test and stabilize the application user interface.
My application works fine and UI seems good as well.

2) If your system was upgraded from version 5.2 or earlier...
No, it didn't. It was upgraded from version 6.2.

3) Verify that the current system locale is the same as your base language (text in the original application). Do not run the wizard in a locale other than your base language.
Ok, I set 'en_US' localization in 'Operator' menu.

And in 'Designer Studio -> UI -> Localization tools -> Locale Settings'

4) If your application uses text strings in a way that does not create references...
Yes, my application has some Java code, there is the getLocalizedValue method used.
I added some field values in my localized rule sets, and it works fine.

5) Determine what language packs you have on your system. To acquire a pack, contact Pegasystems Global Services. Install language packs before you use the wizard.
My application has two language packs: RuleSetName_uk and RuleSetName_ru

A brief overview of Localization Wizard settings:







So, after all of these steps I don't get any changes on my Sections.

Thank you.

***Edited by Moderator Marissa to update categories***

Low-Code App Development Dev/Designer Studio
Moderation Team has archived post
Share this page LinkedIn