Question

4
Replies
387
Views
MaheshG3 Member since 2013 1 post
Ameriprise Financial
Posted: 2 years ago
Last activity: 2 years 3 months ago
Closed
Solved

No plugin mode long polling logging help needed

We are using Pega call 7.1.34 over Pega 7.2 ; In PROD environment we have presence agent configured as Activex. We piloted couple of users with No plugin mode to remove the browser dependency. We found based on screen recording that

1) For certain calls, even though the call was over and connection cleared, still the line 1 says as connected. We are seeing certain delay in the UI refresh in some times.

2) After some time of inactivity , it can vary from 30 mins to 60 mins, we see no screen pops for further calls. So user had to login in a new session to get proper screen pops.

We didn't create any DSS for the refresh Interval and timeout for long polling , so its going with default as 30 secs and 5 mins.

For above issues, when we changed to com.pega.pegacti settings to debug we are seeing that PEGA CTI is publishing the events fine for the agent. But the UI didn't reflect the line states and the screen pop.

To debug the issue, we want to understand how we can check when was recent polling happened from browser , and what interrupted the browser to send another HTTP request to PEGA CTI to get the events. Previously in ActiveX mode we used to configure screenpop.ini to check whether events received or not. In No plugin mode we are not sure how to check the polling related events , is there a way to log these for debug purposes? Thanks in advance.

Pega Customer Service
Moderation Team has archived post
Share this page LinkedIn