Question

3
Replies
256
Views
AnandKumarA3140 Member since 2016 1 post
TCS
Posted: 2 years ago
Last activity: 1 year 9 months ago
Closed
Solved

Unable to Add Nodes to the SMA

Pega Platform 7.2.2

IBM Websphere 8.5.5.10

While trying to open the node configured in the SMA we are getting the below error

[6/26/18 13:20:26:190 BST] 00000163 DefaultDispat E org.apache.struts2.dispatcher.DefaultDispatcherErrorHandler error Exception occurred during processing request: Method "executeWithoutValidation" failed for object com.pega.jmx.ui.action.AuthenticateAction@8d83a597
ognl.MethodFailedException: Method "executeWithoutValidation" failed for object com.pega.jmx.ui.action.AuthenticateAction@8d83a597 [java.lang.LinkageError: loading constraint violation when resolving method "com/ibm/websphere/management/AdminClient.queryNames(Ljavax/management/ObjectName;Ljavax/management/QueryExp;)Ljava/util/Set;" : loader "com/ibm/ws/classloader/CompoundClassLoader@fe9c831" of class "com/pega/jmx/connection/managenodes/WASRemoteMBeanServerConnection" and loader "org/eclipse/osgi/internal/baseadaptor/DefaultClassLoader@ba59c211" of class "com/ibm/websphere/management/AdminClient" have different types for the method signature]

While checking PDN we found the below article:

https://community.pega.com/support/support-articles/unable-connect-sma-node-due-linkageerror

which says this is due to the Automated deployment of the SMA application .

Query:

There is another environment where we deployed the SMA using Rapid Deployment and the SMA is working fine whereas we did the deployment in this environment(where we face issue) using UrbanCode and we are facing the issue.

System Administration SR Parallel
Moderation Team has archived post
Share this page LinkedIn