Question

2
Replies
1156
Views
Wojciech Raczkowski (WojciechR)
Quad Graphics

Quad Graphics
PL
WojciechR Member since 2016 11 posts
Quad Graphics
Posted: September 13, 2017
Last activity: September 13, 2017
Posted: 13 Sep 2017 7:16 EDT
Last activity: 13 Sep 2017 11:20 EDT
Closed

Queue item is stuck in Now-Processing status ONLY on Dev

Hello


Queue item instead of being processed is stuck in Now-Processing status. I've read all posts on PDN regarding this issue but the problem is that in my case the problem exists only on Dev and it works fine on Beta and Prod so I'm assuming the problem is not in code. It looks when I review logs that queue activity (name: ProcessNewOrUpdatedIssue) that should be started by the agent is not even executed.


Even if the problem exists on Dev and we had some releases to Beta and Prod problem existed only on Dev. Unfortunately yesterday we finally released this problem into Beta and Prod as well. Yesterday's release was different from few last because we selected "Include associated data" checbox to migrate access groups also.


I've already restored previous access groups (before migration) on Beta but the issue still exists.


Here is what is see in a log file:


2017-09-13 10:09:09,702 [tp-apr-8080-exec-769] [ STANDARD] [ ] [ Order2Cash:01.06] ( internal.access.DatabaseImpl) ERROR qg-stg1.pegacloud.io|127.0.0.1 - Encountered problem when performing a Commit com.pega.pegarules.pub.database.LockGoneException: Save, Delete or Commit has failed because lock "SYSTEM-QUEUE-PLANNERISSUEUPDATES SYSTEM-QUEUE-PLANNERISSUEUPDATES 1505296847938000WEB_127.0.0.1_I-092F3C3B93E674" is not held From: (H1B525205F948AE5FBF34304E2E942375:127.0.0.1)


Hello

Queue item instead of being processed is stuck in Now-Processing status. I've read all posts on PDN regarding this issue but the problem is that in my case the problem exists only on Dev and it works fine on Beta and Prod so I'm assuming the problem is not in code. It looks when I review logs that queue activity (name: ProcessNewOrUpdatedIssue) that should be started by the agent is not even executed.

Even if the problem exists on Dev and we had some releases to Beta and Prod problem existed only on Dev. Unfortunately yesterday we finally released this problem into Beta and Prod as well. Yesterday's release was different from few last because we selected "Include associated data" checbox to migrate access groups also.

I've already restored previous access groups (before migration) on Beta but the issue still exists.

Here is what is see in a log file:

2017-09-13 10:09:09,702 [tp-apr-8080-exec-769] [ STANDARD] [ ] [ Order2Cash:01.06] ( internal.access.DatabaseImpl) ERROR qg-stg1.pegacloud.io|127.0.0.1 - Encountered problem when performing a Commit com.pega.pegarules.pub.database.LockGoneException: Save, Delete or Commit has failed because lock "SYSTEM-QUEUE-PLANNERISSUEUPDATES SYSTEM-QUEUE-PLANNERISSUEUPDATES 1505296847938000WEB_127.0.0.1_I-092F3C3B93E674" is not held From: (H1B525205F948AE5FBF34304E2E942375:127.0.0.1)

2017-09-13 10:54:07,634 [ PegaRULES-Batch-51] [ STANDARD] [ ] [ Order2Cash:01.06] ( internal.async.AgentQueue) ERROR - Agent Order2Cash #4: System-Queue-PlannerIssueUpdates.ProcessNewOrUpdatedIssue encountered an execution error. Restarting after delay. com.pega.pegarules.pub.PRRuntimeException: unable to execute agent: Order2Cash #4: System-Queue-PlannerIssueUpdates.ProcessNewOrUpdatedIssue

Thanks for any help!

***Updated by moderator: Lochan to mask ip address***

Data Integration System Administration Upgrades
Moderation Team has archived post, This thread is closed to future replies. Content and links will no longer be updated. If you have the same/similar Question, please write a new Question.